Back to overview
Maintenance

Scheduled Maintenance

Mar 3, 2026 at 9:00am UTC  –  Mar 3, 2026 at 9:25am UTC
Affected services
OpenScholar App Health Check

Resolved
Mar 3, 2026 at 9:25am UTC

The scheduled maintenance has been completed. Thank you for your patience!

Created
Mar 3, 2026 at 9:00am UTC

OpenScholar will undergo regular maintenance which may result in a brief period of reduced performance or unavailability.