Back to overview
Downtime
Outage
Feb 24 at 06:05am EST
Affected services
OpenScholar App Health Check
Resolved
Feb 24 at 06:53am EST
We’re back! OpenScholar should be up and running. Thanks for bearing with us.
Affected services
Created
Feb 24 at 06:05am EST
We are investigating an incident that is causing sites to be unavailable.
Affected services